Home > Configure Static Route – GNS3 Lab

Configure Static Route – GNS3 Lab

December 3rd, 2010 Go to comments

In this tutorial we will connect two routers via static route with GNS3.

Static route and Dynamic route

Static route tells the device exactly where to send traffic, no matter what. Static route is often used when your network has only a few routers or there is only one route from a source to a destination. Dynamic routes, on the other hand, use a routing protocol to determine the best path and the routes can be changed depending on specific parameters (like bandwidth, delay, cost…). With dynamic routes, routers can communicate with each other to exchange routing information. In ROUTE 642-902 you will learn about dynamic routing protocols such as OSPF, EIGRP and BGP (RIP is also a dynamic routing protocol but it is not mentioned in ROUTE).

The simple syntax of static route:

ip route destination-network-address subnet-mask {next-hop-IP-address | exit-interface}
+ destination-network-address: destination network address of the remote network
+ subnet mask: subnet mask of the destination network
+ next-hop-IP-address: the IP address of the receiving interface on the next-hop router
+ exit-interface: the local interface of this router where the packets will go out

Now we consider a real-world example of static routing. Suppose that your company has 2 branches located in New York and Chicago. As the administrator of the network, you are tasked to connect them so that employees in the two LANs can communicate with each other. After careful consideration you decided to connect them via static route.

Configure_Static_Route_topology.jpg

In GNS3, place 2 routers and connect them as the image below, I used IOS c2600-bin-mz.123-6f.bin to save some RAM (only require 64MB/router). We will use two loopback interfaces to simulate two Ethernet LANs.

Configure_Static_Route_topology_gns3.jpg

Configuring interfaces on R0

R0(config)#interface s0/0
R0(config-if)#ip address 12.12.12.1 255.255.255.0
R0(config-if)#no shutdown
R0(config-if)#interface lo0
R0(config-if)#ip address 10.0.0.1 255.0.0.0
R0(config-if)#exit

Configuring interfaces on R1

R0(config)#interface s0/0
R0(config-if)#ip address 12.12.12.2 255.255.255.0
R0(config-if)#no shutdown
R0(config-if)#interface lo0
R0(config-if)#ip address 172.16.0.1 255.255.0.0
R0(config-if)#exit

Now if we check the routing table of R0 & R1 by the command show ip route on both R0 and R1

On R0:
R0# show ip route

Configure_Static_Route_show_ip_routeR0.jpg

The letter “C” means “connected” or “directly connected”. So there are 2 networks that are directly connected to R0: 10.0.0.0/8 and 12.12.12.0

On R1

R1# show ip route

Configure_Static_Route_show_ip_routeR1.jpg

Configuring static route on R0

R0(config)#ip route 172.16.0.0 255.255.0.0 12.12.12.2

Configuring static route on R1

R1(config)#ip route 10.0.0.0 255.0.0.0 12.12.12.1

Notice that static route works one-way. It means we have to add static route to both R0 and R1 so that R0 and R1 can communicate.

Configure_Static_Route_show_ip_routeR0_static.jpg


Configure_Static_Route_show_ip_routeR1_static.jpg

Now try to ping each far end network

Configure_Static_Route_ping.jpg

(Note: In fact, R0 can successfully ping R1 right after adding the static route to R0)

Administrative distance of a static route.

After adding two static routes in R0 & R1 routers, the routing tables of two routers contain these lines:

S 10.0.0.0/8 [1/0] via 12.12.12.1 (on R1)
S 172.16.0.0/16 [1/0] via 12.12.12.2 (on R0)

The “S” letter tells us this is a static route. The networks 10.0.0.0/8 and 172.16.0.0/16 are the destinations of this static route and if the routers want to reach them they must send packets to 12.12.12.1 (on R1) and 12.12.12.2 (on R2). These parameters are straightforward and easy to understand. But what is [1/0]? Well, 1 is the administrative distance (AD) and 0 is the metric of that static route.

The administrative distance is a measure of trustworthiness where lower numbers are considered to be more trustworthy than higher numbers. The route with the lowest administrative distance value is the preferred route that the router selects. Administrative distance is the value from 0 to 255.

Directly connected routes have an administrative distance of 0. Static routes have an administrative distance
of 1 so in the outputs above you will see the administrative distance of both static routes are 1.

The router treats a static route pointing to an interface the same as a connected interface so the its AD is 0. If you configure a static route pointing to an exiting interface (for example: “ip route 172.16.0.0 255.255.0.0 s0/0” on R0) then the AD will not be shown.

(For your information, EIGRP has an administrative distance of 90. IGRP has an administrative distance of 100. OSPF has an administrative distance of 110. And RIP has an administrative distance of 120)

Comments (24) Comments
Comment pages
1 2 372
  1. monty
    October 8th, 2012

    I do it with both GNS 3 and packet trace but it does not work good I dont know what is the problem?

  2. willkoolz
    October 30th, 2012

    Check out GNS3 workbench…it has training and a fully loaded ubuntu 10.10 vmware image preloaded w/ ccna labs, GNS3 and documentation.

    http://rednectar.net/gns3-workbench/

    This is what I use plus when you add this to 9tut, you are set. Peace

  3. jaser
    March 19th, 2013

    thanks 9tut

  4. MICKAL
    March 26th, 2013

    THANKS 9TUT

  5. Ahsan
    April 2nd, 2013

    Good Examples with Picture :) Thanku

  6. ANONNYOS
    June 5th, 2013

    j’ai deux routeurs et deux virtuel box guest et j’arrive pas a les router avec un routage statique pouvez vous m’aidé et merci d’avance ^^

  7. ANONNYOS
    June 5th, 2013

    voila mon e-mail hassanefes@hotmail.com

  8. Stoan k
    June 25th, 2013

    This site is helpful indeed,i’ve been out f class 4 a while due 2 work commitments bt nw i cn catch up coz f dis mouth watering tutoria. Thanx CCNA family

  9. Anonymous
    September 19th, 2013

    hiiiii,
    this is tumendra bisen. i am preparing the ccna certification exam. if you have latest dumps and sumulator so plz send me on my email
    tumendra24bisen@gmail.com.so that i can prepare 100%.

  10. irfan
    April 10th, 2014

    this is very good topic it he;lp me alot for understanding static routing thanx alot

  11. Anonymous
    September 18th, 2014

    its very good and informative website

  12. Anonymous
    February 17th, 2015

    Hi,
    Why R0#ping 172.16.0.2 not succeed ?

  13. jenny
    March 9th, 2015

    what is the commands for configuring the ipv6 in gns3
    also how to assign the ipv6 address in sysyem and process ping

  14. SELVA AATHI
    October 14th, 2015

    HELLO CCNA WARRIORS,
    I NEED THE RECENT DUMPS FOR MY CCNA PREPARATION. I’M NOT FROM COMPUTER SCIENCE BACK GROUND… SO IF ANYONE PROVIDE ME THE DUMPS THEN IT WILL BE EASY FOR ME TO CLEAR THE CCNA EXAM WITHOUT LOSING MY MONEY… SO THOSE WHO HAVE DUMPS SEND TO MY MAIL-ID: atheeswarens@yahoo.com

  15. Anonymous
    January 19th, 2016

    y r all these stupid people keep asking to send them dumps?

  16. VOKE
    May 27th, 2016

    Someone send me CCNA dumps please am sitting for my exam in 2 weeks {email not allowed}

  17. VOKE
    May 27th, 2016

    Someone send me CCNA dumps please am sitting for my exam in 2 weeks time..My Skype name:kevin_Phostine

  18. Anonymous
    July 29th, 2016

    Please I need dumps fast as I dont want to lose my money

  19. Afridi
    July 30th, 2016

    I need CCNA dumps

  20. Afridi
    July 30th, 2016

    I need CCNA dumps on {email not allowed}

  21. Afridi
    July 30th, 2016

    {email not allowed}

  22. sonu
    February 22nd, 2017

    I am unable to download packet tracer , can anyone help me here…

  23. riki
    February 27th, 2017

    HELLO CCNA WARRIORS,
    I NEED THE RECENT DUMPS FOR MY CCNA PREPARATION. I’M NOT FROM COMPUTER SCIENCE BACK GROUND… SO IF ANYONE PROVIDE ME THE DUMPS THEN IT WILL BE EASY FOR ME TO CLEAR THE CCNA EXAM WITHOUT LOSING MY MONEY… SO THOSE WHO HAVE DUMPS SEND TO MY MAIL-ID: {email not allowed}

  24. akshay
    December 30th, 2019

    how to configure in 3 route

Comment pages
1 2 372
Add a Comment